How do I resolve "bulk upload failed" when uploading with PAT?
Issue
When trying to upload a Lookup Table with Panther Analysis Tool (PAT), I see the error message "bulk upload failed to upload a lookup table".
Resolution
To help alleviate this issue, update your PAT installation to version 0.19.0 or newer and add the --batch
option to your upload command. This option separates large groups of files in a bulk upload into smaller groups, reducing the likelihood of a timeout.
Another suggestion is to manually delete the LUTs and re-upload them via PAT.
If the issue persists after you perform the above steps, please contact our support team for assistance.
Cause
One known cause of this issue is a timeout, due to uploading too many Lookup Tables at once.