Issue

When trying to add a new allowed IAM principal role to my SQS log source integration the following error occurs:

Failed to update source, please try again later

Resolution

To resolve this issue, please check for the following:

Cause

This issue can occur when the role as listed does not exist in the AWS account provided; AWS will not allow the policy to be updated to include the non-existent role. See the AWS docs on this error here: https://aws.amazon.com/premiumsupport/knowledge-center/iam-trust-policy-error/