How do I resolve the error "Failed to update Access configuration and retrieve metadata from URL" when setting up JumpCloud SSO

Last updated: February 25, 2026

Issue

When trying to configure SSO authentication with JumpCloud using Panther's SAML documentation, the following error occurs:

"Failed to update Access configuration and retrieve metadata from URL"

Resolution

To resolve this issue:

  1. Navigate to your JumpCloud SSO configuration

  2. Enable the "Declare Redirect Endpoint" option in your JumpCloud SSO settings

  3. Once enabled, retry the SSO configuration in Panther

Cause

This issue occurs when JumpCloud is configured with HTTP-POST binding only. Panther requires an HTTP-Redirect binding in order to process the SAML metadata correctly.