Issue

Why are certain Heroku logs failing to be parsed in Panther? I see the following error message in the Panther Console:

Source received events recently that we are unable to classify

Resolution

This error can be ignored.  But if you wish to resolve errors like this in the future, try to remove line breaks in your Heroku commands.

Cause

This is a bug with Heroku logging where commands that include a line break are split across multiple lines in the log.