Why does navigating to a detection page in the Panther Console cause browser lag or lockup?

Last updated: January 21, 2025

Issue

When accessing a detection page in the Panther Console, why does my internet browser lag or lock up? In some cases, I'm not able to interact with the page before the browser locks up.

Resolution

To resolve this issue, run a Data Replay for the detection with a small data set. If a replay seems stuck, it’s likely still processing and should eventually complete.

Cause

It's likely that Data Replay was previously used for the detection whose page you are attempting to view. When accessing a detection in Panther where Data Replay was previously used, the browser automatically attempts to load the old replay data. This can result in significant lag or even freezing, particularly if the replay involved a large data set or generated a high number of alerts.

Panther is working to improve how replays load to reduce browser strain.