Issue

When trying to find user.authentication.auth_via_mfa okta events using Panther Search, they do not appear. When I query select * from okta_systemlog where eventType = "user.authentication.auth_via_mfa" and p_occurs_since(7d) in Panther Data Explorer, the following error occurs:

Your query did not return any results

However, the events can be found in the Okta admin console. How can I troubleshoot this?

Resolution

To troubleshoot this issue:

If the issue still persists, please contact your Support team and include answers to the following questions:

Cause

This issue can occur when querying the wrong database. Using Fully Qualified Table Names (FQTNs) wherever possible can help eliminate ambiguity around which database to use and prevent accidentally querying the wrong database.