How do I fix "Duplicate row detected during DML action" error when uploading data to a Lookup Table in Panther?

Last updated: November 14, 2025

Issue

When trying to upload data for my Lookup Table (LUT), I am getting a lookup update failed...duplicate row detected during DML action error when there are no duplicate rows.

Resolution

To resolve this issue, you can either:

  1. Delete your LUT and re-create the LUT it under a new name.

  2. Reach out to Panther Support to truncate the Snowflake History Table (if preserving the history of the LUT isn’t critical for your use case)

Cause

If you happen to create a Lookup Table with a duplicate entry and then fix it, this issue will arise when uploading the fixed data again. This is because Panther retains the original data in a Snowflake history table using the initial table name.

Therefore, you'll need to either create a completely new table in the database or truncate the history of the lookup table.