When trying to run the command make install in my local panther-analysis repo cloned from GitHub, I get multiple errors starting with the following text:
Installing dependencies from Pipfile.lock ... An error occurred while installing aiohttp==3.8.1 ; python_version >= '3.6'
To resolve this issue:
- Check the version of panther-analysis repo and PAT and make sure that everything is up-to-date.
- Check your Python version. Check the required python_version in the Makefile (e.g. 3.9) and confirm that you're running the correct version of Python.
- Set the correct Python version using
pipenvto use the correct version through an alias, if it's using a different version.
One potential cause for this error message is that pipenv might be using the system Python installation (e.g. 3.10) by default, instead of the one defined by pyenv (e.g. 3.9).