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Panther Knowledge Base

How to Fix "Invalid Redirect" for Panther's Zoom Integration

Issue

After setting up an OAuth app and a Zoom Log Source (as detailed in the Zoom onboarding page), you're asked to authorize the Log Source in Panther. But when you click the button, a browser window pops up, saying "Invalid Redirect":

{"status":false,"errorCode":4700,"errorMessage":"Invalid redirect url","result":null}

Resolution

To resolve this issue:

  1. Sign in to the Zoom Marketplace..
  2. In the top right, click Manage.
  3. A list of your Zoom apps should appear. Click the app used for the Panther integration to edit it.
  4. Ensure that Redirect URL supplied by Panther during the Log Source set up is copied correctly, and that it's pasted into the Redirect URL field and the OAuth allow list.

Cause

The Redirect URL points to the internet address where the Panther integration app lives. Adding the URL to the OAuth allow list means that Zoom will allow communication to and from that address. If it isn't specified, Zoom will, by default, deny all requests from Panther.