How do I resolve a "behind schedule" System Error for scheduled query in Panther?
Issue
Why am I receiving the following System Error?
Query X is Y behind schedule, check query history for errors or performance issues
Resolution
This issue will resolve itself. The error appears when a query is moving slowly but not timing out.
Cause
Possible causes:
- Can be caused by a slow query that does not time out but the delay affects the scheduled frequency of the query.
- Can be caused by a Snowflake or AWS outage leading to the query needing to catch up. This can be verified through the Panther search history and checking the run times.