Why does running a query in Panther Data Explorer cause my page to crash or become unresponsive?
Issue
For some queries, clicking "Run" in the Data Explorer causes the browser tab to freeze, or even close abruptly. In some cases, I see a popup in the browser warning that the tab has crashed. If I close the tab and then look at my query history, I see the query succeed, but navigating to the query results will crash again.
Resolution
To resolve this issue, try running your query again, but with the following adjustments:
- Add a reasonable
LIMIT
, for exampleLIMIT
10
- If you are using
SELECT * FROM
, change your query to select specific columns instead.- For example:
SELECT specificColumn FROM
- For example:
- If you are already selecting specific columns, try to reduce the number of columns returned.
- If you are using
ORDER BY
, try to time bound your query as well. For examplep_occurs_since('24 hours')
Cause
This behavior is commonly caused by either a large amount of rows returned, or by a large amount of data within a row.
The most common scenario where this issue occurs is if you try to perform a SELECT * FROM panther_monitor.public.classification_failures
table because this table has a payload column which can contain a lot of data.